Weekend Certification Sale 70% Discount Offer - Ends in 0d 00h 00m 00s - Coupon code: best70

SPLK-1002 Splunk Core Certified Power User Exam Questions and Answers

Questions 4

Which of the following data model are included In the Splunk Common Information Model (CIM) add-on? (select all that apply)

Options:

A.

Alerts

B.

Email

C.

Database

D.

User permissions

Buy Now
Questions 5

Which of the following statements about calculated fields in Splunk is true?

Options:

A.

Calculated fields cannot be chained together to create more complex fields

B.

Calculated fields can be chained together to create more complex fields.

C.

Calculated fields can only be used in dashboards.

D.

Calculated fields can only be used in saved reports.

Buy Now
Questions 6

We can use the rename command to _____ (Select all that apply.)

Options:

A.

Change indexed fields

B.

Exclude fields from our search results

C.

Extract new fields from our data using regular expressions

D.

Give a field a new name at search time

Buy Now
Questions 7

Which of the following definitions describes a macro named "samplemacro" that accepts two arguments?

Options:

A.

Examplemacro [1,2]

B.

samplemacro(1,2)

C.

u amp -CJEUCXG (2)

D.

samplemacro[2]

Buy Now
Questions 8

To which of the following can a field alias be applied?

Options:

A.

Data found in a lookup table.

B.

Either a calculated field or an extracted field.

C.

Only one single field in a dataset.

D.

A given host, source, or sourcetype.

Buy Now
Questions 9

Which search commands allow a user to access data model summaries?

Options:

A.

pivot, stats, and datamodel

B.

pivot, tstats, and datamodel

C.

transaction, tstats, and datamodel

D.

stats, tstats, and datamodel

Buy Now
Questions 10

During the validation step of the Field Extractor workflow:

Select your answer.

Options:

A.

You can remove values that aren't a match for the field you want to define

B.

You can validate where the data originated from

C.

You cannot modify the field extraction

Buy Now
Questions 11

When a search returns __________, you can view the results as a list.

Options:

A.

a list of events

B.

transactions

C.

statistical values

Buy Now
Questions 12

Which is not a comparison operator in Splunk

Options:

A.

< =

B.

=

C.

!=

D.

>

E.

?=

Buy Now
Questions 13

Which of the following statements describe GET workflow actions?

Options:

A.

GET workflow actions must be configured with POST arguments.

B.

Configuration of GET workflow actions includes choosing a sourcetype.

C.

Label names for GET workflow actions must include a field name surrounded by dollar signs.

D.

GET workflow actions can be configured to open the URT link in the current window or in a new window

Buy Now
Questions 14

If there are fields in the data with values that are " " or empty but not null, which of the following would add a value?

Options:

A.

| eval notNULL = if(isnull (notNULL), “0” notNULL)

B.

| eval notNULL = if(isnull (notNULL), “0”

C.

| eval notNULL = “” | nullfill value=0 notNULL

D.

| eval notNULL = “” fillnull value=0 notNULL

Buy Now
Questions 15

To create a tag, which of the following conditions must be met by the user?

Options:

A.

Identify at least one field:value pair.

B.

Have the Power role at a minimum.

C.

Be able to edit the sourcetype the tag applies to.

D.

Must have the tag capability associated with their user role.

Buy Now
Questions 16

Which workflow action type performs a secondary search?

Options:

A.

POST

B.

Drilldown

C.

GET

D.

Search

Buy Now
Questions 17

This function of the stats command allows you to identify the number of values a field has.

Options:

A.

max

B.

distinct_count

C.

fields

D.

count

Buy Now
Questions 18

Calculated fields can be based on which of the following?

Options:

A.

Tags

B.

Extracted fields

C.

Output fields for a lookup

D.

Fields generated from a search string

Buy Now
Questions 19

Where are the descriptions of the data models that come with the Splunk Common Information Model (CIM) Add-on documented?

Options:

A.

Search and reporting user manual.

B.

CIM Add-on manual.

C.

Pivot users manual.

D.

Datamodel command reference guide.

Buy Now
Questions 20

Which workflow action method can be used the action type is set to link?

Options:

A.

GET

B.

PUT

C.

Search

D.

UPDATE

Buy Now
Questions 21

Clicking a SEGMENT on a chart, ________.

Options:

A.

drills down for that value

B.

highlights the field value across the chart

C.

adds the highlighted value to the search criteria

Buy Now
Questions 22

Which field will be used to populate the field if the productName and product:d fields have values for a given event?

| eval productINFO=coalesco(productName,productid)

Options:

A.

Both field values will be used and the product INFO field will become a multivalue field for the given event.

B.

The value for the productName field because it appears first.

C.

Neither field value will be used and the field will be assigned a NULL value for the given event.

D.

The value for the field because it appears second.

Buy Now
Questions 23

The time range specified for a historical search defines the ____________ .------questionable on ans

Options:

A.

Amount of data shown on the timeline as data streams in

B.

Amount of data fetched from index matching that time range

C.

Time range for the static results

Buy Now
Questions 24

Marty has multiple data sources that contain fields with IP Address values. What knowledge object should he use to normalize the fields so his data is CIM compliant?

Options:

A.

Event type

B.

Field alias

C.

Field extraction

D.

Tag

Buy Now
Questions 25

When multiple event types with different color values are assigned to the same event, what determines the color displayed for the events?

Options:

A.

Rank

B.

Weight

C.

Priority

D.

Precedence

Buy Now
Questions 26

When should the regular expression mode of Field Extractor (FX) be used? (select all that apply)

Options:

A.

For data cleanly separated by a space, a comma, or a pipe character.

B.

For data in a CSV (comma-separated value) file.

C.

For data with multiple, different characters separating fields.

D.

For unstructured data.

Buy Now
Questions 27

Which of the following eval commands will provide a new value for host from src if it exists?

Options:

A.

| eval host = if (isnu11 (src), src, host)

B.

| eval host = if (NOT src = host, src, host)

C.

| eval host = if (src = host, src, host)

D.

| eval host = if (isnotnull (src), src, host)

Buy Now
Questions 28

What commands can be used to group events from one or more data sources?

Options:

A.

eval, coalesce

B.

transaction, stats

C.

stats, format

D.

top, rare

Buy Now
Questions 29

A report scheduled to run every 15 mins. but takes 17 mins. to complete is in danger of being_____.

Options:

A.

skipped or deferred

B.

automatically accelerated

C.

deleted

D.

all of the above

Buy Now
Questions 30

What are search macros?

Options:

A.

Lookup definitions in lookup tables.

B.

Reusable pieces of search processing language.

C.

A method to normalize fields.

D.

Categories of search results.

Buy Now
Questions 31

When a search is executed, what must occur before field aliases can be assigned?

Options:

A.

Perform lookups

B.

Process calculated fields

C.

Create event types

D.

Extract fields

Buy Now
Questions 32

Which command can include both an over and a by clause to divide results into sub-groupings?

Options:

A.

chart

B.

stats

C.

xyseries

D.

transaction

Buy Now
Questions 33

What does the fillnull command replace null values with, it the value argument is not specified?

Options:

A.

0

B.

N/A

C.

NaN

D.

NULL

Buy Now
Questions 34

A search contains example(100,200). What is the name of the macro?

Options:

A.

example(2)

B.

example(var1,var2)

C.

example($,$)

D.

example[2]

Buy Now
Questions 35

Which of the following statements describes calculated fields?

Options:

A.

Calculated fields are only used on fields added by lookups.

B.

Calculated fields are a shortcut for repetitive and complex eval commands.

C.

Calculated fields are a shortcut for repetitive and complex calc commands.

D.

Calculated fields automatically calculate the simple moving average for indexed fields.

Buy Now
Questions 36

A macro has another macro nested within it, and this inner macro requires an argument. How can the user pass this argument into the SPL?

Options:

A.

An argument can be passed through the outer macro.

B.

An argument can be passed to the outer macro by nesting parentheses.

C.

There is no way to pass an argument to the inner macro.

D.

An argument can be passed to the inner macro by nesting parentheses.

Buy Now
Questions 37

What approach is recommended when using the Splunk Common Information Model (CIM) add-on to normalize data?

Options:

A.

Consult the CIM data model reference tables.

B.

Run a search using the authentication command.

C.

Consult the CIM event type reference tables.

D.

Run a search using the correlation command.

Buy Now
Questions 38

A user wants to convert numeric field values to strings and also to sort on those values.

Which command should be used first, the eval or the sort?

Options:

A.

It doesn't matter whether eval or sort is used first.

B.

Convert the numeric to a string with eval first, then sort.

C.

Use sort first, then convert the numeric to a string with eval.

D.

You cannot use the sort command and the eval command on the same field.

Buy Now
Questions 39

What is the purpose of a calculated field?

Options:

A.

To automatically add fields to the index using an eval expression rather than manually including an eval command.

B.

To manually add and remove fields at search time related to statistical functions.

C.

To automatically add fields at search time using an eval expression rather than manually including an eval command.

D.

To manually add fields at search time and check for syntax errors.

Buy Now
Questions 40

When using | timchart by host, which filed is representted in the x-axis?

Options:

A.

date

B.

host

C.

time

D.

-time

Buy Now
Questions 41

When performing a regex field extraction with the Field Extractor (FX), a data type must be chosen before a sample event can be selected. Which of the following data types are supported?

Options:

A.

index or source

B.

sourcetype or host

C.

index or sourcetype

D.

sourcetype or source

Buy Now
Questions 42

Which of the following commands support the same set of functions?

Options:

A.

stats, eval, table

B.

search, where, eval

C.

stats, chart, timechart

D.

transaction, chart, timechart

Buy Now
Questions 43

When creating a POST workflow action, what can a user define as the POST arguments?

Options:

A.

Static text only

B.

A combination of static text and field value pairs

C.

A combination of field value pairs and the search query

D.

Field value pairs only

Buy Now
Questions 44

Which syntax is used to represent an argument in a macro definition?

Options:

A.

"argument"

B.

%argument%

C.

‘argument’

D.

$argument$

Buy Now
Questions 45

When using | timechart by host, which field is represented in the x-axis?

Options:

A.

date

B.

host

C.

time

D.

_time

Buy Now
Questions 46

Why are tags useful in Splunk?

Options:

A.

Tags look for less specific data.

B.

Tags visualize data with graphs and charts.

C.

Tags group related data together.

D.

Tags add fields to the raw event data.

Buy Now
Questions 47

To identify all of the contributing events within a transaction that contains at least one REJECT event, which syntax is correct?

Options:

A.

Index-main | REJECT trans sessionid

B.

Index-main | transaction sessionid | search REJECT

C.

Index=main | transaction sessionid | whose transaction=reject

D.

Index=main | transaction sessionid | where transaction=reject’’

Buy Now
Questions 48

Which of the following search modes automatically returns all extracted fields in the fields sidebar?

Options:

A.

Fast

B.

Smart 

C.

C. Verbose

Buy Now
Questions 49

Splunk alerts can be based on search that run______. (Select all that apply.)

Options:

A.

in real-time

B.

on a regular schedule

C.

and have no matching events

Buy Now
Questions 50

When would transaction be used instead of stats?

Options:

A.

To group events based on a single field value.

B.

To see results of a calculation.

C.

To have a faster and more efficient search.

D.

To group events based on start/end values.

Buy Now
Questions 51

How are arguments defined within the macro search string?

Options:

A.

Şarg$

B.

'arg'

C.

%arg%

D.

"arg"

Buy Now
Questions 52

In the following eval statement, what is the value of description if the status is 503? index=main | eval description=case(status==200, "OK", status==404, "Not found", status==500, "Internal Server Error")

Options:

A.

The description field would contain no value.

B.

The description field would contain the value 0.

C.

The description field would contain the value "Internal Server Error".

D.

This statement would produce an error in Splunk because it is incomplete.

Buy Now
Questions 53

A calculated field is a shortcut for performing repetitive, long, or complex transformations using which of the following commands?

Options:

A.

transaction

B.

lookup

C.

stats

D.

eval

Buy Now
Questions 54

In the Field Extractor Utility, this button will display events that do not contain extracted fields.

Select your answer.

Options:

A.

Selected-Fields

B.

Non-Matches

C.

Non-Extractions

D.

Matches

Buy Now
Questions 55

Which search would limit an "alert" tag to the "host" field?

Options:

A.

tag=alert

B.

host::tag::alert

C.

tag==alert

D.

tag::host=alert

Buy Now
Questions 56

How are event types different from saved reports?

Options:

A.

Event types cannot be used to organize data into categories.

B.

Event types include formatting of the search results.

C.

Event types can be shared with Splunk users and added to dashboards.

D.

Event types do not include a time range.

Buy Now
Questions 57

Using the Field Extractor (FX) tool, a value is highlighted to extract and give a name to a new field. Splunk has not successfully extracted that value from all appropriate events. What steps can be taken so Splunk successfully extracts the value from all appropriate events? (select all that apply)

Options:

A.

Select an additional sample event with the Field Extractor (FX) and highlight the missing value in the event.

B.

Re-ingest the data and attempt to extract from a new dataset.

C.

Click on the event where the field was not extracted and choose “Change to Delimited".

D.

Edit the regular expression manually.

Buy Now
Questions 58

When would a user select delimited field extractions using the Field Extractor (FX)?

Options:

A.

When a log file has values that are separated by the same character, for example, commas.

B.

When a log file contains empty lines or comments.

C.

With structured files such as JSON or XML.

D.

When the file has a header that might provide information about its structure or format.

Buy Now
Questions 59

Why would the following search produce multiple transactions instead of one?

SPLK-1002 Question 59

Options:

A.

The maxspan option is not included.

B.

The transaction command has a limit of 1000 events per transaction.

C.

The transaction and commands cannot be used together.

D.

The stats list () function is used.

Buy Now
Questions 60

Which of the following searches will return all clientip addresses that start with 108?

Options:

A.

… | where like (clientip, “108.% )

B.

… | where (clientip, "108. %")

C.

… | where (clientip=108. % )

D.

… | search clientip=108

Buy Now
Questions 61

Consider the following search:

Index=web sourcetype=access_combined

The log shows several events that share the same JSESSIONID value (SD404K289O2F151). View the events as a group. From the following list, which search groups events by JSESSIONID?

Options:

A.

index=web sourcetype=access_combined SD404K289O2F151 I table JSESSIONID

B.

index=web sourcetype=access_combined JSESSIONID < SD404K289O2F151 >

C.

index=web sourcetype=access_combined I highlight JSESSIONID I search SD404K289O2F151

D.

index-web sourcetype=access_combined I transaction JSESSIONID I search SD404K289O2F151

Buy Now
Questions 62

Which of the following statements describes POST workflow actions?

Options:

A.

Configuration of a POST workflow action includes choosing a sourcetype.

B.

POST workflow actions can be configured to send email to the URI location.

C.

By default, POST workflow action are shown in both the event and field menus.

D.

POST workflow actions can be configured to send POST arguments to the URI location.

Buy Now
Questions 63

A user runs the following search:

index—X sourcetype=Y I chart count (domain) as count, sum (price) as sum by product, action usenull=f useother—f

Which of the following table headers match the order this command creates?

Options:

A.

The chart command does not allow for multiple statistical functions.

B.

Product, sum: addtocart, sum: remove, sum: purchase, count: addtocart, count: remove, count: purchase

C.

Product, count: addtocart, count: remove, count: purchase, sum: addtocart, sum: remove, sum: purchase

D.

Count: product, sum: product, count: action, sum: action

Buy Now
Questions 64

When using the transaction command, what does the argument maxspan do?

Options:

A.

Sets the maximum total time between events in a transaction.

B.

Sets the maximum length of all events within a transaction.

C.

Sets the maximum total time between the earliest and latest events in a transaction.

D.

Sets the maximum length that any single event can reach to be included in the transaction.

Buy Now
Questions 65

Which of the following statements describes the command below (select all that apply)

Sourcetype=access_combined | transaction JSESSIONID

Options:

A.

An additional filed named maxspan is created.

B.

An additional field named duration is created.

C.

An additional field named eventcount is created.

D.

Events with the same JSESSIONID will be grouped together into a single event.

Buy Now
Questions 66

What is the Splunk Common Information Model (CIM)?

Options:

A.

The CIM is a prerequisite that any data source must meet to be successfully onboarded into Splunk.

B.

The CIM provides a methodology to normalize data from different sources and source types.

C.

The CIM defines an ecosystem of apps that can be fully supported by Splunk.

D.

The CIM is a data exchange initiative between software vendors.

Buy Now
Questions 67

When performing a regular expression (regex) field extraction using the Field Extractor (FX), what happens when the require option is used?

Options:

A.

The regex can no longer be edited.

B.

The field being extracted will be required for all future events.

C.

The events without the required field will not display in searches.

D.

Only events with the required string will be included in the extraction.

Buy Now
Questions 68

Which workflow uses field values to perform a secondary search?

Options:

A.

POST

B.

Action

C.

Search

D.

Sub-Search

Buy Now
Questions 69

When creating a data model, which root dataset requires at least one constraint?

Options:

A.

Root transaction dataset

B.

Root event dataset

C.

Root child dataset

D.

Root search dataset

Buy Now
Questions 70

Which statement is true?

Options:

A.

Pivot is used for creating datasets.

B.

Data model are randomly structured datasets.

C.

Pivot is used for creating reports and dashboards.

D.

In most cases, each Splunk user will create their own data model.

Buy Now
Questions 71

Which of the following fields should be normalized using the Splunk Common Information Model (CIM) based on their relationship?

Options:

A.

src_ip, dest_ip

B.

src_ip, source_ip

C.

index, sourcetype

D.

src_ip, src_port

Buy Now
Questions 72

Which method in the Field Extractor would extract the port number from the following event? |

10/20/2022 - 125.24.20.1 ++++ port 54 - user: admin < web error >

Options:

A.

Delimiter

B.

rex command

C.

The Field Extractor tool cannot extract regular expressions.

D.

Regular expression

Buy Now
Questions 73

Which of the following actions can the eval command perform?

Options:

A.

Remove fields from results.

B.

Create or replace an existing field.

C.

Group transactions by one or more fields.

D.

Save SPL commands to be reused in other searches.

Buy Now
Questions 74

For the following search, which field populates the x-axis?

index=security sourcetype=linux secure | timechart count by action

Options:

A.

action

B.

source type

C.

_time

D.

time

Buy Now
Questions 75

Which of the following are valid options to speed up reports? (Select all the apply.)

Options:

A.

Edit permissions

B.

Edit description

C.

Edit acceleration

D.

Edit schedule

Buy Now
Questions 76

What is the correct way to name a macro with two arguments?

Options:

A.

us_sales2

B.

us_sales(1,2)

C.

us_sale,2

D.

us_sales(2)

Buy Now
Questions 77

What does the fillnull command do in this search?

index=main sourcetype=http:log | fillnull value="Unknown"

Options:

A.

Set the values of the field to null when it is "Unknown".

B.

Set all fields that are null to "Unknown".

C.

Set the values of the field to "Unknown" if it is null.

D.

Set all fields with the value of "Unknown" to null.

Buy Now
Questions 78

Why would the transaction command be used instead of the stats command?

Options:

A.

The transaction command can perform calculations on fields.

B.

The transaction command is less resource-intensive.

C.

The transaction command keeps the raw data for each event.

D.

The transaction command has better search-time performance.

Buy Now
Questions 79

In this search, __________ will appear on the y-axis. SEARCH: sourcetype=access_combined status!=200 | chart count over host

Options:

A.

status

B.

host

C.

count

Buy Now
Questions 80

Which knowledge object is used to normalize field names to comply with the Splunk Common Information Model (CIM)?

Options:

A.

Field alias

B.

Event types

C.

Search workflow action

D.

Tags

Buy Now
Questions 81

Selected fields are displayed ______each event in the search results.

Options:

A.

below

B.

interesting fields

C.

other fields

D.

above

Buy Now
Questions 82

Which knowledge Object does the Splunk Common Information Model (CIM) use to normalize data. in addition to field aliases, event types, and tags?

Options:

A.

Macros

B.

Lookups

C.

Workflow actions

D.

Field extractions

Buy Now
Questions 83

Which of the following can be saved as an event type?

Options:

A.

index=server_48 sourcetype=BETA_881 code=220

B.

index=server_48 sourcetype=BETA_881 code=220 | stats count by code

C.

index=server_48 sourcetype=BETA_881 code=220 | inputlookup append=t servercode.csv

D.

index=server_48 sourcetype=BETA_881 code=220 | stats where code > 220

Buy Now
Questions 84

When using the transaction command, how are evicted transactions identified?

Options:

A.

Closed_txn field is set to o, or false.

B.

Max_txn field is set to O, or false.

C.

Txn_field is set to 1, or true.

D.

open_txn field is set to 1, or true.

Buy Now
Questions 85

Given the following eval statement:

...| eval fieldl - if(isnotnull(fieldl),fieldl,0), field2 = if(isnull < field2 > , "NO-VALUE", fieid2)

Which of the following is the equivalent using f ilinull?

Options:

A.

There is no equivalent expression using f ilinull

B.

... t filinull values=(0,"NO-VALUE") fields=(fieldl,field2)

C.

... I filinull value=0 fieldl I fillnull fields

D.

... I fillnull fieldl I filinull value="NO-VALUE" field2

Buy Now
Questions 86

Which option of the transaction command would be used to specify the maximum time between events in a transaction?

Options:

A.

maxpause

B.

maxspan

C.

duration

D.

 eventcount

Buy Now
Questions 87

Which delimiters can the Field Extractor (FX) detect? (select all that apply)

Options:

A.

Tabs

B.

Pipes

C.

Spaces

D.

Commas

Buy Now
Questions 88

This is what Splunk uses to categorize the data that is being indexed.

Options:

A.

sourcetype

B.

index

C.

source

D.

host

Buy Now
Questions 89

Which of the following definitions describes a macro named “samplemacro” that accepts two arguments?

Options:

A.

samplemacro(2)

B.

samplemacro(1,2)

C.

samplemacro[2]

D.

samplemacro[1,2]

Buy Now
Questions 90

In which of the following scenarios is an event type more effective than a saved search?

Options:

A.

When a search should always include the same time range.

B.

When a search needs to be added to other users' dashboards.

C.

When the search string needs to be used in future searches.

D.

When formatting needs to be included with the search string.

Buy Now
Questions 91

Which of the following describes the I transaction command?

Options:

A.

It is an SPL command that groups at least two events together based on shared values in selected fields.

B.

It allows an exchange of data from one Splunk index to another Splunk index.

C.

It is an SPL command that groups events together with shared values in selected fields.

D.

It allows an exchange of data from one Splunk system to another Splunk system.

Buy Now
Questions 92

Which of the following Statements about macros is true? (select all that apply)

Options:

A.

Arguments are defined at execution time.

B.

Arguments are defined when the macro is created.

C.

Argument values are used to resolve the search string at execution time.

D.

Argument values are used to resolve the search string when the macro is created.

Buy Now
Questions 93

Which tool uses data models to generate reports and dashboard panels without using SPL?

Options:

A.

Visualization tab

B.

Pivot

C.

Datasets

D.

splunk CIM

Buy Now
Exam Code: SPLK-1002
Exam Name: Splunk Core Certified Power User Exam
Last Update: Jul 19, 2026
Questions: 313

PDF + Testing Engine

$134.99

Testing Engine

$99.99

PDF (Q&A)

$84.99